summaryrefslogtreecommitdiffstats
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorShizZy <shizzy@6bit.net>2013-09-26 23:34:48 +0200
committerShizZy <shizzy@6bit.net>2013-09-26 23:34:48 +0200
commit8bb0c457bca110ca80fd3d09e78a794600a7221a (patch)
tree31023ba8d5839b836d4b49b31f9a74261c0540d1 /src/citra/CMakeLists.txt
parentadded meta_file_system to project (diff)
downloadyuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar.gz
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar.bz2
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar.lz
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar.xz
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.tar.zst
yuzu-8bb0c457bca110ca80fd3d09e78a794600a7221a.zip
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
new file mode 100644
index 000000000..3a76b5045
--- /dev/null
+++ b/src/citra/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(SRCS src/citra.cpp
+ src/emuwindow/emuwindow_glfw.cpp)
+
+# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
+if (NOT X11_xf86vmode_LIB)
+ set(X11_xv86vmode_LIB Xxf86vm)
+endif()
+
+add_executable(citra ${SRCS})
+target_link_libraries(citra core common ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} GLEW rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
+
+#install(TARGETS citra RUNTIME DESTINATION ${bindir})