summaryrefslogtreecommitdiffstats
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-05-01 01:56:25 +0200
committerarchshift <admin@archshift.com>2014-05-01 01:56:47 +0200
commita7f3ed003d03c79f83c1c354329e5ce47f6940e7 (patch)
tree76b0dd731d81ea91917f8a9c34c4e7c90db4f407 /src/citra/CMakeLists.txt
parentSome more experimentation (diff)
downloadyuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.gz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.bz2
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.lz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.xz
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.tar.zst
yuzu-a7f3ed003d03c79f83c1c354329e5ce47f6940e7.zip
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index 25f476895..ee3cb55cf 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -3,12 +3,12 @@ set(SRCS citra.cpp
set(HEADS citra.h
resource.h)
-# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
-if (NOT X11_xf86vmode_LIB)
- set(X11_xv86vmode_LIB Xxf86vm)
-endif()
-
add_executable(citra ${SRCS} ${HEADS})
-target_link_libraries(citra core common video_core iconv pthread ${COREFOUNDATION_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+
+if (APPLE)
+ target_link_libraries(citra core common video_core iconv pthread ${COREFOUNDATION_LIBRARY} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+else()
+ target_link_libraries(citra core common video_core pthread ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+endif()
#install(TARGETS citra RUNTIME DESTINATION ${bindir})