summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-08-27 02:41:14 +0200
committerGitHub <noreply@github.com>2021-08-27 02:41:14 +0200
commitd10d480642d82082e84004141e345631f308f34b (patch)
treec57b894d8896374962934c71f19c9c214c72a44b /src/common/CMakeLists.txt
parentMerge pull request #6922 from yuzu-emu/revert-6832-scheduler-improvements (diff)
parentlogging: Display backtrace on crash (diff)
downloadyuzu-d10d480642d82082e84004141e345631f308f34b.tar
yuzu-d10d480642d82082e84004141e345631f308f34b.tar.gz
yuzu-d10d480642d82082e84004141e345631f308f34b.tar.bz2
yuzu-d10d480642d82082e84004141e345631f308f34b.tar.lz
yuzu-d10d480642d82082e84004141e345631f308f34b.tar.xz
yuzu-d10d480642d82082e84004141e345631f308f34b.tar.zst
yuzu-d10d480642d82082e84004141e345631f308f34b.zip
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 57922b51c..316c4dedc 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -176,3 +176,6 @@ if (MSVC)
else()
target_link_libraries(common PRIVATE zstd)
endif()
+if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND CMAKE_CXX_COMPILER_ID STREQUAL GNU)
+ target_link_libraries(common PRIVATE backtrace)
+endif()