summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-10-02 03:41:41 +0200
committerGitHub <noreply@github.com>2021-10-02 03:41:41 +0200
commit3a33519598063175fb7c16c67e32784ed97d5017 (patch)
treea055bc9022da01a96ed2f15cd45853793fb82df2 /src/core/CMakeLists.txt
parentMerge pull request #7114 from ameerj/msvc-ubuntu-version (diff)
parentCMakeLists: Remove BoxCat build option (diff)
downloadyuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.gz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.bz2
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.lz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.xz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.zst
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 7140d0db8..aa3b26628 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -106,8 +106,6 @@ add_library(core STATIC
file_sys/vfs_concat.h
file_sys/vfs_layered.cpp
file_sys/vfs_layered.h
- file_sys/vfs_libzip.cpp
- file_sys/vfs_libzip.h
file_sys/vfs_offset.cpp
file_sys/vfs_offset.h
file_sys/vfs_real.cpp
@@ -653,13 +651,6 @@ add_library(core STATIC
tools/freezer.h
)
-if (YUZU_ENABLE_BOXCAT)
- target_sources(core PRIVATE
- hle/service/bcat/backend/boxcat.cpp
- hle/service/bcat/backend/boxcat.h
- )
-endif()
-
if (MSVC)
target_compile_options(core PRIVATE
/we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
@@ -690,12 +681,7 @@ endif()
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::Opus zip)
-
-if (YUZU_ENABLE_BOXCAT)
- target_compile_definitions(core PRIVATE -DYUZU_ENABLE_BOXCAT)
- target_link_libraries(core PRIVATE httplib nlohmann_json::nlohmann_json)
-endif()
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::Opus)
if (ENABLE_WEB_SERVICE)
target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)