summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2014-09-19 04:27:06 +0200
committerbunnei <bunneidev@gmail.com>2014-09-19 04:27:06 +0200
commita9630a9d2b432bea7bdfef4aa462035b98b34517 (patch)
tree258010943e989fc61a2a439ff15ead7ed3d11a6f /src/core/CMakeLists.txt
parentMerge pull request #107 from lioncash/sprintf (diff)
parentKernel: Implement the Close command for Archive, File and Directory. (diff)
downloadyuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar.gz
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar.bz2
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar.lz
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar.xz
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.tar.zst
yuzu-a9630a9d2b432bea7bdfef4aa462035b98b34517.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 1f358ec8d..2b26292fd 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -23,6 +23,11 @@ set(SRCS
arm/interpreter/armvirt.cpp
arm/interpreter/thumbemu.cpp
file_sys/archive_romfs.cpp
+ file_sys/archive_sdmc.cpp
+ file_sys/file_romfs.cpp
+ file_sys/file_sdmc.cpp
+ file_sys/directory_romfs.cpp
+ file_sys/directory_sdmc.cpp
hle/kernel/address_arbiter.cpp
hle/kernel/archive.cpp
hle/kernel/event.cpp
@@ -77,6 +82,13 @@ set(HEADERS
arm/arm_interface.h
file_sys/archive.h
file_sys/archive_romfs.h
+ file_sys/archive_sdmc.h
+ file_sys/file.h
+ file_sys/file_romfs.h
+ file_sys/file_sdmc.h
+ file_sys/directory.h
+ file_sys/directory_romfs.h
+ file_sys/directory_sdmc.h
hle/kernel/address_arbiter.h
hle/kernel/archive.h
hle/kernel/event.h