summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-01-17 09:55:10 +0100
committerGitHub <noreply@github.com>2021-01-17 09:55:10 +0100
commite8401964b4cb617223554e147091f109dc870ba5 (patch)
tree0e963c000006ca547044bdc628177311fa0dc585 /src/core/CMakeLists.txt
parentMerge pull request #5745 from lioncash/documentation (diff)
parentcore/cmake: Enforce Wclass-memaccess (diff)
downloadyuzu-e8401964b4cb617223554e147091f109dc870ba5.tar
yuzu-e8401964b4cb617223554e147091f109dc870ba5.tar.gz
yuzu-e8401964b4cb617223554e147091f109dc870ba5.tar.bz2
yuzu-e8401964b4cb617223554e147091f109dc870ba5.tar.lz
yuzu-e8401964b4cb617223554e147091f109dc870ba5.tar.xz
yuzu-e8401964b4cb617223554e147091f109dc870ba5.tar.zst
yuzu-e8401964b4cb617223554e147091f109dc870ba5.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 99310dc50..2f6b22747 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -645,6 +645,7 @@ else()
-Werror=implicit-fallthrough
-Werror=sign-compare
+ $<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>