summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorameerj <52414509+ameerj@users.noreply.github.com>2022-11-23 00:38:23 +0100
committerameerj <52414509+ameerj@users.noreply.github.com>2022-11-30 00:50:49 +0100
commit37bc5118ea8f5891741faba8963ce9ae5f88e946 (patch)
tree0beccc4f6ee5ddc627ddf59edebc659ce0611074 /src/input_common/CMakeLists.txt
parentexternals: Update dynarmic (diff)
downloadyuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar.gz
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar.bz2
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar.lz
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar.xz
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.tar.zst
yuzu-37bc5118ea8f5891741faba8963ce9ae5f88e946.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index cc6f0ffc0..77bfe4b58 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -34,6 +34,7 @@ add_library(input_common STATIC
input_poller.h
main.cpp
main.h
+ precompiled_headers.h
)
if (MSVC)
@@ -63,3 +64,7 @@ target_link_libraries(input_common PRIVATE usb)
create_target_directory_groups(input_common)
target_link_libraries(input_common PUBLIC core PRIVATE common Boost::boost)
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(input_common PRIVATE precompiled_headers.h)
+endif()