summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorgerman77 <juangerman-13@hotmail.com>2021-09-21 00:36:23 +0200
committerNarr the Reg <juangerman-13@hotmail.com>2021-11-25 03:30:23 +0100
commit59b995a9e53f09b9831b03608cfe5ce27c3e3485 (patch)
tree54cf3df8ed6ef572d754267be8339c9a8f25b203 /src/input_common/CMakeLists.txt
parentinput_common: Rewrite udp client (diff)
downloadyuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar.gz
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar.bz2
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar.lz
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar.xz
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.tar.zst
yuzu-59b995a9e53f09b9831b03608cfe5ce27c3e3485.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 9c0c82138..8cdcd315b 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -5,6 +5,8 @@ add_library(input_common STATIC
drivers/keyboard.h
drivers/mouse.cpp
drivers/mouse.h
+ drivers/sdl_driver.cpp
+ drivers/sdl_driver.h
drivers/tas_input.cpp
drivers/tas_input.h
drivers/touch_screen.cpp
@@ -29,8 +31,6 @@ add_library(input_common STATIC
motion_from_button.h
motion_input.cpp
motion_input.h
- sdl/sdl.cpp
- sdl/sdl.h
)
if (MSVC)
@@ -57,8 +57,8 @@ endif()
if (ENABLE_SDL2)
target_sources(input_common PRIVATE
- sdl/sdl_impl.cpp
- sdl/sdl_impl.h
+ drivers/sdl_driver.cpp
+ drivers/sdl_driver.h
)
target_link_libraries(input_common PRIVATE SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)