summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-11-15 12:22:01 +0100
committerLioncash <mathew1800@gmail.com>2020-11-22 10:50:03 +0100
commit5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a (patch)
tree4f65578a7b6cd6d5f379b177919583bcfb8e71f3 /src/input_common/CMakeLists.txt
parentMerge pull request #4944 from lioncash/system-rem (diff)
downloadyuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar.gz
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar.bz2
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar.lz
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar.xz
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.tar.zst
yuzu-5c4774e8ce1d3c5391402f4b2244cfb4dfe7d57a.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 7b39a38c1..1d1b2e08a 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -31,6 +31,9 @@ add_library(input_common STATIC
if (MSVC)
target_compile_options(input_common PRIVATE
+ /W4
+ /WX
+
# 'expression' : signed/unsigned mismatch
/we4018
# 'argument' : conversion from 'type1' to 'type2', possible loss of data (floating-point)
@@ -46,6 +49,7 @@ if (MSVC)
)
else()
target_compile_options(input_common PRIVATE
+ -Werror
-Werror=conversion
-Werror=ignored-qualifiers
-Werror=implicit-fallthrough