summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-03 20:10:06 +0100
committerGitHub <noreply@github.com>2022-12-03 20:10:06 +0100
commit75e16547f8977e8b2b07723b04bcc3cbe999d566 (patch)
tree7a7795d68f636d1a3f4972c3ea36c1d50db564c5 /src/input_common/CMakeLists.txt
parentMerge pull request #9289 from liamwhite/fruit-company (diff)
parentCMake: Consolidate common PCH headers (diff)
downloadyuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.gz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.bz2
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.lz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.xz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.zst
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 193127d0a..e41da2726 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -34,6 +34,7 @@ add_library(input_common STATIC
input_poller.h
main.cpp
main.h
+ precompiled_headers.h
)
if (MSVC)
@@ -67,3 +68,7 @@ target_link_libraries(input_common PRIVATE usb)
create_target_directory_groups(input_common)
target_link_libraries(input_common PUBLIC core PRIVATE common Boost::boost)
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(input_common PRIVATE precompiled_headers.h)
+endif()