summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2022-12-28 23:26:46 +0100
committerLiam <byteslice@airmail.cc>2022-12-28 23:26:46 +0100
commitbe43b62d79cc03f9908ce5036f96a94e9053ba65 (patch)
tree0c55f4709eb56914520aa711f5735a96877fda1f /src/input_common/CMakeLists.txt
parentcmake: ignore missing package finders for packages with submodule fallbacks (diff)
downloadyuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar.gz
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar.bz2
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar.lz
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar.xz
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.tar.zst
yuzu-be43b62d79cc03f9908ce5036f96a94e9053ba65.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index f24c89b04..cef2c4d52 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -4,14 +4,10 @@
add_library(input_common STATIC
drivers/camera.cpp
drivers/camera.h
- drivers/gc_adapter.cpp
- drivers/gc_adapter.h
drivers/keyboard.cpp
drivers/keyboard.h
drivers/mouse.cpp
drivers/mouse.h
- drivers/sdl_driver.cpp
- drivers/sdl_driver.h
drivers/tas_input.cpp
drivers/tas_input.h
drivers/touch_screen.cpp
@@ -62,8 +58,17 @@ if (ENABLE_SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)
endif()
+if (ENABLE_LIBUSB)
+ target_sources(input_common PRIVATE
+ drivers/gc_adapter.cpp
+ drivers/gc_adapter.h
+ )
+ target_link_libraries(input_common PRIVATE libusb::usb)
+ target_compile_definitions(input_common PRIVATE HAVE_LIBUSB)
+endif()
+
create_target_directory_groups(input_common)
-target_link_libraries(input_common PUBLIC core PRIVATE common Boost::boost libusb::usb)
+target_link_libraries(input_common PUBLIC core PRIVATE common Boost::boost)
if (YUZU_USE_PRECOMPILED_HEADERS)
target_precompile_headers(input_common PRIVATE precompiled_headers.h)