summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorNarr the Reg <juangerman-13@hotmail.com>2022-12-20 18:34:33 +0100
committerNarr the Reg <juangerman-13@hotmail.com>2023-01-20 01:05:20 +0100
commitd80e6c399bf8196646cca5ac1265d122638bb96b (patch)
tree328254642e4edcd5e0aadfe9190f3f133d34708e /src/input_common/CMakeLists.txt
parentMerge pull request #9556 from vonchenplus/draw_texture (diff)
downloadyuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.gz
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.bz2
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.lz
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.xz
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.tar.zst
yuzu-d80e6c399bf8196646cca5ac1265d122638bb96b.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index cef2c4d52..41885d0d2 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -51,8 +51,13 @@ endif()
if (ENABLE_SDL2)
target_sources(input_common PRIVATE
+ drivers/joycon.cpp
+ drivers/joycon.h
drivers/sdl_driver.cpp
drivers/sdl_driver.h
+ helpers/joycon_driver.cpp
+ helpers/joycon_driver.h
+ helpers/joycon_protocol/joycon_types.h
)
target_link_libraries(input_common PRIVATE SDL2::SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)