summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-06-04 17:40:52 +0200
committerGitHub <noreply@github.com>2020-06-04 17:40:52 +0200
commit34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0 (patch)
tree95b864039ba58c858b0bb89c2eb6b56a25475d22 /src/video_core/CMakeLists.txt
parentMerge pull request #4039 from FearlessTobi/port-5376 (diff)
parentDefault init labels and use initializer list for macro engine (diff)
downloadyuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar.gz
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar.bz2
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar.lz
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar.xz
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.tar.zst
yuzu-34d4abc4f9c264fb4dfc32b9b44aaeecaa4695a0.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index d6ee82836..2bf8d68ce 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -25,6 +25,12 @@ add_library(video_core STATIC
engines/shader_bytecode.h
engines/shader_header.h
engines/shader_type.h
+ macro/macro.cpp
+ macro/macro.h
+ macro/macro_interpreter.cpp
+ macro/macro_interpreter.h
+ macro/macro_jit_x64.cpp
+ macro/macro_jit_x64.h
fence_manager.h
gpu.cpp
gpu.h
@@ -36,8 +42,6 @@ add_library(video_core STATIC
gpu_thread.h
guest_driver.cpp
guest_driver.h
- macro_interpreter.cpp
- macro_interpreter.h
memory_manager.cpp
memory_manager.h
morton.cpp