summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLC <mathew1800@gmail.com>2020-10-09 03:10:31 +0200
committerGitHub <noreply@github.com>2020-10-09 03:10:31 +0200
commit61b246a3a952e704549f3d3a191fcb7442420fb1 (patch)
tree22d6d7e5af345c81d404229370efe4c36c835135 /src/video_core/CMakeLists.txt
parentMerge pull request #4677 from german77/ShakeFromButton (diff)
parentvideo_core: Enforce -Wunused-variable and -Wunused-but-set-variable (diff)
downloadyuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar.gz
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar.bz2
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar.lz
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar.xz
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.tar.zst
yuzu-61b246a3a952e704549f3d3a191fcb7442420fb1.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index da9e9fdda..2be455679 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -273,5 +273,11 @@ endif()
if (MSVC)
target_compile_options(video_core PRIVATE /we4267)
else()
- target_compile_options(video_core PRIVATE -Werror=conversion -Wno-error=sign-conversion -Werror=switch)
+ target_compile_options(video_core PRIVATE
+ -Werror=conversion
+ -Wno-error=sign-conversion
+ -Werror=switch
+ -Werror=unused-variable
+ -Werror=unused-but-set-variable
+ )
endif()