summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2019-02-14 16:06:48 +0100
committerGitHub <noreply@github.com>2019-02-14 16:06:48 +0100
commitfcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70 (patch)
tree05acdede20385a9d738666c59fb63aa9ca055a6a /src/video_core/CMakeLists.txt
parentMerge pull request #2115 from lioncash/local (diff)
parentvk_device: Abstract device handling into a class (diff)
downloadyuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar.gz
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar.bz2
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar.lz
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar.xz
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.tar.zst
yuzu-fcc3aa0bbf4a1343f90dfc7a93afc31e770c3a70.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 1db0d031d..d35a738d5 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -101,6 +101,16 @@ add_library(video_core STATIC
video_core.h
)
+if (ENABLE_VULKAN)
+ target_sources(video_core PRIVATE
+ renderer_vulkan/declarations.h
+ renderer_vulkan/vk_device.cpp
+ renderer_vulkan/vk_device.h)
+
+ target_include_directories(video_core PRIVATE ../../externals/Vulkan-Headers/include)
+ target_compile_definitions(video_core PRIVATE HAS_VULKAN)
+endif()
+
create_target_directory_groups(video_core)
target_link_libraries(video_core PUBLIC common core)