summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2022-12-03 19:32:24 +0100
committerLiam <byteslice@airmail.cc>2022-12-04 16:12:26 +0100
commit6d2c59737177dba09a0a2a31e96276addf52c172 (patch)
tree9bb6050c056d66f880557e3fd5b3058638afd66d /src/yuzu_cmd/CMakeLists.txt
parentMerge pull request #9300 from ameerj/pch (diff)
downloadyuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.gz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.bz2
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.lz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.xz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.zst
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.zip
Diffstat (limited to 'src/yuzu_cmd/CMakeLists.txt')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index daabf608d..094387ade 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -44,8 +44,9 @@ target_include_directories(yuzu-cmd PRIVATE ${RESOURCES_DIR})
target_include_directories(yuzu-cmd PRIVATE ../../externals/Vulkan-Headers/include)
if (YUZU_USE_EXTERNAL_SDL2)
- target_compile_definitions(yuzu-cmd PRIVATE -DYUZU_USE_EXTERNAL_SDL2)
- target_include_directories(yuzu-cmd PRIVATE ${PROJECT_BINARY_DIR}/externals/SDL/include)
+ target_link_libraries(yuzu-cmd PRIVATE SDL2-static)
+else()
+ target_link_libraries(yuzu-cmd PRIVATE SDL2)
endif()
if(UNIX AND NOT APPLE)