summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 1 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05bffe68e..b2fbe8806 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -458,22 +458,7 @@ if (UNIX AND NOT APPLE)
endif()
if (NOT YUZU_USE_BUNDLED_FFMPEG)
# Use system installed FFmpeg
- find_package(FFmpeg 4.3 QUIET COMPONENTS ${FFmpeg_COMPONENTS})
-
- if (FFmpeg_FOUND)
- # Overwrite aggregate defines from FFmpeg module to avoid over-linking libraries.
- # Prevents shipping too many libraries with the AppImage.
- set(FFmpeg_LIBRARIES "")
- set(FFmpeg_INCLUDE_DIR "")
-
- foreach(COMPONENT ${FFmpeg_COMPONENTS})
- set(FFmpeg_LIBRARIES ${FFmpeg_LIBRARIES} ${FFmpeg_LIBRARY_${COMPONENT}} CACHE PATH "Paths to FFmpeg libraries" FORCE)
- set(FFmpeg_INCLUDE_DIR ${FFmpeg_INCLUDE_DIR} ${FFmpeg_INCLUDE_${COMPONENT}} CACHE PATH "Path to FFmpeg headers" FORCE)
- endforeach()
- else()
- message(WARNING "FFmpeg not found or too old, falling back to externals")
- set(YUZU_USE_BUNDLED_FFMPEG ON)
- endif()
+ find_package(FFmpeg 4.3 REQUIRED QUIET COMPONENTS ${FFmpeg_COMPONENTS})
endif()
# Prefer the -pthread flag on Linux.