summaryrefslogtreecommitdiffstats
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
index c8b745d55..ad7a2b363 100644
--- a/externals/getopt/CMakeLists.txt
+++ b/externals/getopt/CMakeLists.txt
@@ -1,11 +1,9 @@
-set(SRCS
- getopt.c
- )
-set(HEADERS
- getopt.h
- )
+add_library(getopt
+ getopt.c
+ getopt.h
+)
+
+create_target_directory_groups(getopt)
-create_directory_groups(${SRCS} ${HEADERS})
-add_library(getopt ${SRCS} ${HEADERS})
target_compile_definitions(getopt PUBLIC STATIC_GETOPT)
target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})