summaryrefslogtreecommitdiffstats
path: root/externals/nx_tzdb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/nx_tzdb/CMakeLists.txt')
-rw-r--r--externals/nx_tzdb/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/externals/nx_tzdb/CMakeLists.txt b/externals/nx_tzdb/CMakeLists.txt
index db00e9d40..8429f82e5 100644
--- a/externals/nx_tzdb/CMakeLists.txt
+++ b/externals/nx_tzdb/CMakeLists.txt
@@ -20,8 +20,10 @@ endif()
if ("${GNU_DATE}" STREQUAL "GNU_DATE-NOTFOUND")
set(CAN_BUILD_NX_TZDB false)
endif()
-if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Windows")
+if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Windows" OR ANDROID)
# tzdb_to_nx currently requires a posix-compliant host
+ # MinGW and Android are handled here due to the executable format being different from the host system
+ # TODO (lat9nq): cross-compiling support
set(CAN_BUILD_NX_TZDB false)
endif()