summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 55b113297..0696201df 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -43,7 +43,7 @@ if (MSVC)
/Zo
/permissive-
/EHsc
- /std:c++latest
+ /std:c++20
/utf-8
/volatile:iso
/Zc:externConstexpr
@@ -51,8 +51,10 @@ if (MSVC)
/Zc:throwingNew
/GT
+ # Modules
+ /experimental:module- # Disable module support explicitly due to conflicts with precompiled headers
+
# External headers diagnostics
- /experimental:external # Enables the external headers options. This option isn't required in Visual Studio 2019 version 16.10 and later
/external:anglebrackets # Treats all headers included by #include <header>, where the header file is enclosed in angle brackets (< >), as external headers
/external:W0 # Sets the default warning level to 0 for external headers, effectively turning off warnings for external headers