summaryrefslogtreecommitdiffstats
path: root/src/android/app/src/main/jni/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/android/app/src/main/jni/CMakeLists.txt')
-rw-r--r--src/android/app/src/main/jni/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/android/app/src/main/jni/CMakeLists.txt b/src/android/app/src/main/jni/CMakeLists.txt
new file mode 100644
index 000000000..373c0e8bd
--- /dev/null
+++ b/src/android/app/src/main/jni/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_library(yuzu-android SHARED
+ emu_window/emu_window.cpp
+ emu_window/emu_window.h
+ id_cache.cpp
+ id_cache.h
+ native.cpp
+ native.h
+)
+
+set_property(TARGET yuzu-android PROPERTY IMPORTED_LOCATION ${FFmpeg_LIBRARY_DIR})
+
+target_link_libraries(yuzu-android PRIVATE audio_core common core input_common)
+target_link_libraries(yuzu-android PRIVATE android camera2ndk EGL glad inih jnigraphics log)
+
+set(CPACK_PACKAGE_EXECUTABLES ${CPACK_PACKAGE_EXECUTABLES} yuzu-android)