summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 68c67507b..d1d177b51 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -51,6 +51,8 @@ if (NOT MSVC)
-Werror=implicit-fallthrough
-Werror=reorder
-Werror=sign-compare
+ -Werror=shadow
+ -Werror=unused-parameter
-Werror=unused-variable
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>