summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index e43e6e1bb..8e7b93acb 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -1,10 +1,22 @@
-set(SRCS video_core.cpp
+set(SRCS clipper.cpp
+ command_processor.cpp
+ primitive_assembly.cpp
+ rasterizer.cpp
utils.cpp
+ vertex_shader.cpp
+ video_core.cpp
renderer_opengl/renderer_opengl.cpp)
-set(HEADERS video_core.h
+set(HEADERS clipper.h
+ command_processor.h
+ math.h
+ primitive_assembly.h
+ rasterizer.h
utils.h
+ video_core.h
renderer_base.h
+ vertex_shader.h
+ video_core.h
renderer_opengl/renderer_opengl.h)
add_library(video_core STATIC ${SRCS} ${HEADERS})