summaryrefslogtreecommitdiffstats
path: root/src/web_service/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/web_service/CMakeLists.txt')
-rw-r--r--src/web_service/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/web_service/CMakeLists.txt b/src/web_service/CMakeLists.txt
index 3f75d97d1..19534b9e4 100644
--- a/src/web_service/CMakeLists.txt
+++ b/src/web_service/CMakeLists.txt
@@ -4,6 +4,7 @@
add_library(web_service STATIC
announce_room_json.cpp
announce_room_json.h
+ precompiled_headers.h
telemetry_json.cpp
telemetry_json.h
verify_login.cpp
@@ -17,3 +18,7 @@ add_library(web_service STATIC
create_target_directory_groups(web_service)
target_link_libraries(web_service PRIVATE common network nlohmann_json::nlohmann_json httplib cpp-jwt)
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(web_service PRIVATE precompiled_headers.h)
+endif()