summaryrefslogtreecommitdiffstats
path: root/net-nds/pamldapd/pamldapd-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/pamldapd/pamldapd-0.3.ebuild')
-rw-r--r--net-nds/pamldapd/pamldapd-0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-nds/pamldapd/pamldapd-0.3.ebuild b/net-nds/pamldapd/pamldapd-0.3.ebuild
new file mode 100644
index 0000000..11365aa
--- /dev/null
+++ b/net-nds/pamldapd/pamldapd-0.3.ebuild
@@ -0,0 +1,34 @@
+EAPI=8
+inherit go-module
+# max 80 chars
+DESCRIPTION="Simple LDAP server, uses PAM as backend"
+HOMEPAGE="https://github.com/eisin/pamldapd"
+SRC_URI="http://ni.4a.si./sijanec/pamldapd/snapshot/pamldapd-${PV}.tar.gz http://splet.4a.si./dir/pamldapd-${PV}-vendor.tar.xz"
+# https://wiki.gentoo.org/wiki/Writing_go_Ebuilds
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+# vsi moji programi so nestabilni (:
+KEYWORDS="*"
+
+DEPEND="acct-user/pamldapd acct-group/pamldapd"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# do not use mirrors to download
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin pamldapd
+ default
+}