summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-10-02 03:41:41 +0200
committerGitHub <noreply@github.com>2021-10-02 03:41:41 +0200
commit3a33519598063175fb7c16c67e32784ed97d5017 (patch)
treea055bc9022da01a96ed2f15cd45853793fb82df2 /CMakeLists.txt
parentMerge pull request #7114 from ameerj/msvc-ubuntu-version (diff)
parentCMakeLists: Remove BoxCat build option (diff)
downloadyuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.gz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.bz2
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.lz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.xz
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.tar.zst
yuzu-3a33519598063175fb7c16c67e32784ed97d5017.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7ea86d8a..bd0f6b978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,16 +29,10 @@ option(YUZU_USE_BUNDLED_FFMPEG "Download/Build bundled FFmpeg" "${WIN32}")
option(YUZU_USE_QT_WEB_ENGINE "Use QtWebEngine for web applet implementation" OFF)
-option(YUZU_ENABLE_BOXCAT "Enable the Boxcat service, a yuzu high-level implementation of BCAT" ON)
-
option(ENABLE_CUBEB "Enables the cubeb audio backend" ON)
option(USE_DISCORD_PRESENCE "Enables Discord Rich Presence" OFF)
-if (NOT ENABLE_WEB_SERVICE)
- set(YUZU_ENABLE_BOXCAT OFF)
-endif()
-
# Default to a Release build
get_property(IS_MULTI_CONFIG GLOBAL PROPERTY GENERATOR_IS_MULTI_CONFIG)
if (NOT IS_MULTI_CONFIG AND NOT CMAKE_BUILD_TYPE)
@@ -422,11 +416,6 @@ if (CONAN_REQUIRED_LIBS)
endif()
include(${CMAKE_BINARY_DIR}/conan.cmake)
- set(CONAN_LIB_OPTIONS
- libzip:with_openssl=False
- libzip:enable_windows_crypto=False
- )
-
conan_check(VERSION 1.24.0 REQUIRED)
# Manually add iconv to fix a dep conflict between qt and sdl2