summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-10 21:42:24 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2015-01-10 21:42:24 +0100
commit57503df97f70250e9713bc3e362915c84a3babfd (patch)
tree6a8cfb199acc5cfd474e18e425ed46dd3419ef6e /CMakeLists.txt
parentFix Windows build (diff)
downloadyuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar.gz
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar.bz2
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar.lz
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar.xz
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.tar.zst
yuzu-57503df97f70250e9713bc3e362915c84a3babfd.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2711336fb..20a5a011a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@ else()
# /GR- - Disable RTTI
# /GS- - No stack buffer overflow checks
# /EHsc - C++-only exception handling semantics
- set(optimization_flags "/MP /MD /Ox /Oy- /DNDEBUG /GR- /GS- /EHsc")
+ set(optimization_flags "/MP /MD /Ox /Oy- /GR- /GS- /EHsc")
# /Zi - Output debugging information
# /Zo - enahnced debug info for optimized builds
set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)
@@ -32,7 +32,11 @@ else()
set(CMAKE_C_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
endif()
+
add_definitions(-DSINGLETHREADED)
+# CMake seems to only define _DEBUG on Windows
+set_property(DIRECTORY APPEND PROPERTY
+ COMPILE_DEFINITIONS $<$<CONFIG:Debug>:_DEBUG> $<$<NOT:$<CONFIG:Debug>>:NDEBUG>)
find_package(PNG QUIET)
if (PNG_FOUND)