summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2016-09-02 04:55:07 +0200
committerbunnei <bunneidev@gmail.com>2016-09-15 23:49:21 +0200
commit8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7 (patch)
tree62c1bd208d4307a26744b29fc88de4582cb0d326 /CMakeLists.txt
parentexternals/boost: Use latest upstream with variant. (diff)
downloadyuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar.gz
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar.bz2
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar.lz
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar.xz
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.tar.zst
yuzu-8410e7891c2abdbe0b76eee3038fb3c8a0eb45d7.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ac3df0e0..3932fd569 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,12 +118,11 @@ else()
endif()
find_package(Boost 1.57.0 QUIET)
-if (Boost_FOUND)
- include_directories(${Boost_INCLUDE_DIRS})
-else()
+if (NOT Boost_FOUND)
message(STATUS "Boost 1.57.0 or newer not found, falling back to externals")
- include_directories(externals/boost)
+ set(Boost_INCLUDE_DIR "${CMAKE_SOURCE_DIR}/externals/boost")
endif()
+include_directories(${Boost_INCLUDE_DIR})
# Include bundled CMake modules
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")