summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ac3df0e0..3932fd569 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,12 +118,11 @@ else()
endif()
find_package(Boost 1.57.0 QUIET)
-if (Boost_FOUND)
- include_directories(${Boost_INCLUDE_DIRS})
-else()
+if (NOT Boost_FOUND)
message(STATUS "Boost 1.57.0 or newer not found, falling back to externals")
- include_directories(externals/boost)
+ set(Boost_INCLUDE_DIR "${CMAKE_SOURCE_DIR}/externals/boost")
endif()
+include_directories(${Boost_INCLUDE_DIR})
# Include bundled CMake modules
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")