summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-02-28 01:46:19 +0100
committerGitHub <noreply@github.com>2023-02-28 01:46:19 +0100
commita78a475815ee20d448fb75db7707d52e974041a2 (patch)
tree3b615fa636a30d183eae2813f350787016eb2edd /CMakeLists.txt
parentMerge pull request #9859 from liamwhite/tmem-use (diff)
parentcmake: fix cpp-jwt build (diff)
downloadyuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar.gz
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar.bz2
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar.lz
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar.xz
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.tar.zst
yuzu-a78a475815ee20d448fb75db7707d52e974041a2.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 274eebe8a..906073602 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -244,6 +244,9 @@ endif()
if (ENABLE_WEB_SERVICE)
find_package(cpp-jwt 1.4 CONFIG)
find_package(httplib 0.12 MODULE)
+ if (NOT cpp-jwt_FOUND OR NOT httplib_FOUND)
+ find_package(OpenSSL 1.1 MODULE COMPONENTS Crypto SSL)
+ endif()
endif()
if (YUZU_TESTS)