summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-09-12 15:17:50 +0200
committerGitHub <noreply@github.com>2023-09-12 15:17:50 +0200
commitce5320c49f6e3c1dc52b9046213366dd0df1612f (patch)
tree58d116258d42771a5ccda31775b127113b1ea256 /CMakeLists.txt
parentci: fix msvc when used with LTO (#11459) (diff)
parentadd a compile time option to allow disabling portable mode (diff)
downloadyuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.gz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.bz2
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.lz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.xz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.zst
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6b158985..3b0891adf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,8 @@ option(YUZU_ENABLE_LTO "Enable link-time optimization" OFF)
option(YUZU_DOWNLOAD_TIME_ZONE_DATA "Always download time zone binaries" OFF)
+option(YUZU_ENABLE_PORTABLE "Allow yuzu to enable portable mode if a user folder is found in the CWD" ON)
+
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
CMAKE_DEPENDENT_OPTION(USE_SYSTEM_MOLTENVK "Use the system MoltenVK lib (instead of the bundled one)" OFF "APPLE" OFF)