summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLC <mathew1800@gmail.com>2020-07-12 18:25:10 +0200
committerGitHub <noreply@github.com>2020-07-12 18:25:10 +0200
commited89bcc767a6c187d834b6b9bb6134190598fc53 (patch)
treeb17d4aaf8b4550d6433ff28a820046957b7a4172 /CMakeLists.txt
parentMerge pull request #3385 from Morph1984/batch-install (diff)
parentCMakeLists: Make use of /std:c++latest on MSVC (diff)
downloadyuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar.gz
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar.bz2
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar.lz
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar.xz
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.tar.zst
yuzu-ed89bcc767a6c187d834b6b9bb6134190598fc53.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88ea04c08..12c0a4284 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,8 +118,15 @@ message(STATUS "Target architecture: ${ARCHITECTURE}")
# Configure C++ standard
# ===========================
-set(CMAKE_CXX_STANDARD 17)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
+if (MSVC)
+ add_compile_options(/std:c++latest)
+
+ # cubeb and boost still make use of deprecated result_of.
+ add_definitions(-D_HAS_DEPRECATED_RESULT_OF)
+else()
+ set(CMAKE_CXX_STANDARD 17)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+endif()
# Output binaries to bin/
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)