summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2022-12-03 19:32:24 +0100
committerLiam <byteslice@airmail.cc>2022-12-04 16:12:26 +0100
commit6d2c59737177dba09a0a2a31e96276addf52c172 (patch)
tree9bb6050c056d66f880557e3fd5b3058638afd66d /src/video_core/CMakeLists.txt
parentMerge pull request #9300 from ameerj/pch (diff)
downloadyuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.gz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.bz2
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.lz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.xz
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.tar.zst
yuzu-6d2c59737177dba09a0a2a31e96276addf52c172.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 97609ded4..5d4821ad2 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -280,9 +280,15 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
)
else()
- target_compile_options(video_core PRIVATE
- -Werror=conversion
+ if (APPLE)
+ # error: declaration shadows a typedef in 'interval_base_set<SubType, DomainT, Compare, Interval, Alloc>'
+ # error: implicit conversion loses integer precision: 'int' to 'boost::icl::bound_type' (aka 'unsigned char')
+ target_compile_options(video_core PRIVATE -Wno-shadow -Wno-unused-local-typedef)
+ else()
+ target_compile_options(video_core PRIVATE -Werror=conversion)
+ endif()
+ target_compile_options(video_core PRIVATE
-Wno-sign-conversion
)