summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 97609ded4..5d4821ad2 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -280,9 +280,15 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
)
else()
- target_compile_options(video_core PRIVATE
- -Werror=conversion
+ if (APPLE)
+ # error: declaration shadows a typedef in 'interval_base_set<SubType, DomainT, Compare, Interval, Alloc>'
+ # error: implicit conversion loses integer precision: 'int' to 'boost::icl::bound_type' (aka 'unsigned char')
+ target_compile_options(video_core PRIVATE -Wno-shadow -Wno-unused-local-typedef)
+ else()
+ target_compile_options(video_core PRIVATE -Werror=conversion)
+ endif()
+ target_compile_options(video_core PRIVATE
-Wno-sign-conversion
)